Highlighted posts

Squeaky, squeally sound??
 
August 17, 2021   •   23 posts   •   166 views
 
94-95 5.0 - Specific
 
 

Monday said — One's a tensioner; other's an idler. I've changed both. No squeeks. You can always spray a little Silicone Lubricant around the back of both, into the bearings if you can - use ...

Read more »

 
Rear seat delete
 
August 17, 2021   •   15 posts   •   102 views
 
Exterior and Interior
 
 

joemomma said — You could probably use something like plexiglass or acrylic if weight is an issue, although to get a rigid "plastic" you'd need to go fairly thick, and that stuff gets heavy quickly. ...

Read more »

 
Timing issues
 
August 17, 2021   •   12 posts   •   72 views
 
94-95 5.0 - Specific
 
 

Project Grey94 said — Thank you sir I have done that this morning and it showing that I am a tooth off number one on top of the distributor so I remove the distributor and moved it a tooth to where ...

Read more »

 
September POTM contest
 
August 17, 2021   •   5 posts   •   53 views
 
Nominations and Voting
 
 

white95 said — Everyone post their favorite picture of their SN95! Anything goes this round. Nomination period will end August 30th. The winner will receive this t-shirt: [image] Depending on ...

Read more »

 
2.6 mammoth on a 2.1 KB
 
August 17, 2021   •   1 post   •   13 views
 
Forced Induction & Tuning
 
 

evil2vgt said — I just had my 2.1 rebuilt and purchased a 2.6 mammoth inlet from Kenne Bell at the same time. I also had them install a spacer for fuel rail clearance. The issue I am having is ...

Read more »

 
Highlighted posts from Tuesday, Aug. 17, 2021
 
August 18, 2021   •   1 post   •   5 views
 
Newsletter Archive
 
 

SN95Newsletter said — Click here to view on the web Highlighted posts Rear seat delete August 16, 2021 * 12 posts * 42 views Exterior and Interior Squeaky, squeally sound?? August 16, 2021 * 19 posts ...

Read more »

 
Engine cutting out at 3k rpm in WOT
 
August 17, 2021   •   30 posts   •   314 views
 
96-04 - 4V Specific
 
 

Venompower said — Looks @TrickVert posted in a thread earlier this year that he had a hole in the rubber s-hose at the fuel pump that only caused pressure issues at higher rpm. This may be the problem ...

Read more »